最新消息:

Intel x520-2万兆网卡因驱动问题导致穿越火线与英雄联盟游戏秒卡

热点问题 死性不改 29315浏览 0评论

【问题现象】

  该网吧采用的是万兆方案,主干光纤,千兆到桌面。网吧从开业到现在为止,一直存在穿越火线与英雄联盟玩30分钟~2个小时左右秒卡问题,这个秒卡与普通秒卡不同,特点在于是玩一段时间之后只卡一下,并非是一直卡,因此这种特殊的现象也给当地的技术人员带来了诸多困惑,处理很很长时间也未能解决。
核心交换机为:融合RHS6824ST交换机,流量控制功能已经关闭。
服务器网卡:Intel Ether Server Adapter X520-2,32G内存。
客户机网卡为:Atheros AR8151 PCI-E千兆网卡,网卡驱动版本为:2.0.11.15,网卡参数已按照要求设置。

  测试时发现,内网传输速度非常不稳定,测速只有10~40MB/S,而且速度不稳定,且内网有丢包现象。


【原因说明】

  经过排查测试发现,是由于服务器网卡驱动导致,使用本站推荐的16.8.1驱动以后,速度达到80MB/S,而且速度非常稳定。


【解决方案】

  服务器是2003系统,更新16.8.1版本网卡驱动后解决,更新驱动后不需要修改网卡参数,修改网卡参数之后可能会导致传输速度下降1~3MB/S。

该网卡驱动适用于2003/2008系统,非常稳定,且性能不错,强烈推荐,下载地址:http://support.icafe8.com/drivers#network


【问题分析】

  对于此类特别的问题现象,处理起来很关键的一点就是不要被表面现象迷惑,从基础的测试开始排查,排查时发现客户机上测试游戏虚拟盘读取速度只有10~20MB/S的速度,最高不超过40MB/S。如上面现象图一样。

  在这个问题环境中,Atheros AR8151网卡没有使用经验,服务器万兆网卡也没有使用经验,万兆交换机全命令行配置,没有web界面,此时怎么办?思路其实很简单,把他变成熟悉的环境,具体的做法:

1、把客户机变成熟悉的环境:

  客户机上用8169网卡测试,其它环境不变,速度只有10~20MB/S左右,波动幅度大,最高40多,最低9MB/S左右,结论:非客户机网卡问题。效果如下图:

2、把交换机和服务器变成普通环境。

  找台客户机,接上硬盘,安装网维大师游戏虚拟盘,把这个普通客户机做成临时服务器,并且将这台临时服务器分别接到主干网络以及和客户机同一个傻瓜交换机上。测试发现速度正常,可以稳定在40MB/S左右(此时客户机还是8169网卡,有40MB/S的速度属于正常范围)。结论:整个局域网正常。

  将客户机的网卡也使用Atheros AR8151网卡,测速发现可稳定达到60MB/S,证明Atheros网卡确实没有问题,局域网也确实没问题。

3、客户机网卡、内部局域网两个陌生的环境已经验证为正常,此时搞服务器。

  客户机网卡,内部局域网都是正常的,那问题只能在服务器上了。以前碰到过的案例,服务器的万兆网卡接在了PCI-E 4X接口会有问题,必须接到8x的PCI-E接口才行,因此想把服务器变成普通千兆网卡,排除万兆网卡问题,谁知种种原因变不成。

  此时只好按照过去的经验,更换驱动。将驱动更新为17.0版本后,速度爆发,达到10MB/S,而且非常稳定-_-。

  在网上查了半天,万兆网卡用什么驱动比较好,但是无果,最后再次换为之前一直在用的16.8.1,结果发现速度再次爆发,达到83MB/S,而且非常稳定,上下波动不超过1MB/S,如下图:

  至此,问题算是解决了,从10MB/S的速度爆发到83MB/S……其实只是网卡驱动的问题~

  在此要对配合解决问题的长沙技术人员“又是春暖花开时,QQ:34393*90*”表示感谢,饿着肚子测试了这么久~不过相信我们彼此也都丰富了自己的经验,希望本次总结能给大家带来一定启发!

  总结成一句建议就是:当你碰到一个不熟悉的环境时,把他变成熟悉的环境,然后再用替换法去验证!当然还有很关键的一点,就是做自我总结,不断的理清自己处理问题的思路,只有这样经验才会丰富起来!

转载请注明:网维大师帮助与支持 » Intel x520-2万兆网卡因驱动问题导致穿越火线与英雄联盟游戏秒卡